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Curve Fitting Overview

Chapter 1

This chapter provides an introduction to curve fitting. It includes information on the following topics:
e The purpose of performing curve fits.
*  The types of curve fits that are available in KaleidaGraph.

*  Choosing an appropriate curve fit model.

1.1 Purpose of Curve Fitting

Curve fitting, also known as regression analysis, is used to find the "best fit" line or curve for a series of data
points. Most of the time, the curve fit will produce an equation that can be used to find points anywhere along
the curve. In some cases, you may not be concerned about finding an equation. Instead, you may just want
to use a curve fit to smooth the data and improve the appearance of your plot. KaleidaGraph provides curve
fits that can be used in both of these scenarios.

1.2 Types of Curve Fits

The curve fits included in KaleidaGraph can be divided into three main categories: Least Squares curve fits,
nonlinear curve fits, and smoothing curve fits. This section provides an overview of each category.

1.2.1 Least Squares Curve Fits

Least Squares is a method of curve fitting that has been popular for a long time. Least Squares minimizes
the square of the error between the original data and the values predicted by the equation. While this
technique may not be the most statistically robust method of fitting a function to a data set, it has the
advantage of being relatively simple (in terms of required computing power) and of being well understood.

The major weakness of the Least Squared method is its sensitivity to outliers in the data. If a data point is
widely different from the majority of the data, it can skew the results of the regression. For this reason, the
data should always be examined for reasonableness before fitting. KaleidaGraph’s Data Selection tool
provides a simple method of graphically removing outliers from a plot.

The five Least Squares fits available in KaleidaGraph are: Linear, Polynomial, Exponential, Logarithmic,
and Power. Section 2.1 contains a description of each fit and Section 2.2 provides an example of applying a
Polynomial curve fit.

1.1 Purpose of Curve Fitting 5
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1.2.2 Nonlinear Curve Fits

Nonlinear curve fitting is accommodated in KaleidaGraph through the General curve fit function. Using this
function, you can define your own equation or choose one from our library of over 100 curve fit definitions.
This is the most powerful fitting option in KaleidaGraph because you can specify virtually any equation to
be fitted to the data.

The General curve fit is based on the Levenberg-Marquardt algorithm and is calculated using an iterative
procedure. KaleidaGraph starts with the initial guesses for the unknown parameters that were supplied with
the equation. It then calculates a Chi Square value that represents the sum of the squared error between the
original data and the calculated fit. During each iteration, KaleidaGraph varies the parameter values slightly
and re-evaluates Chi Square until it finds the best fit.

Chapter 3 contains more information on the use of the General curve fit function.

1.2.3 Smoothing Curve Fits

The smoothing fits in KaleidaGraph are different from the other two types of fits in that these curve fits do
not generate an equation for the resulting curve. This is because there is no single equation that can be used
to represent the curve. These curve fits are useful when you just want to improve the appearance of the plot
by drawing a smooth curve through the data.

The four smoothing fits available in KaleidaGraph are: Smooth, Weighted, Cubic Spline, and Interpolate.
Each one of these curve fits uses a different technique to arrive at the final curve, so you may want to apply
more than one to see which one looks the best.

The Smooth and Interpolate curve fits are based on the same underlying technique, with the Smooth curve
fit incorporating a geometric weight to arrive at the final curve. The Weighted curve fit uses the locally
weighted Least Squares error (Lowess) method. The Cubic Spline curve fit is calculated using a series of
cubic polynomials. Section 4.1 contains a description of each fit and Section 4.2 provides an example of
applying a Cubic Spline curve fit.

1.3 Choosing a Curve Fit Model

Since KaleidaGraph provides a number of different curve fit types and over 100 General curve fit equations,
choosing a model for a particular data set can be a difficult task. When you are deciding on a curve fit model,
it helps to know some of the underlying properties associated with the data to make an educated decision on
which model to use.

Depending on your field of study, you may find that certain equations or families of equations are used on
a regular basis. For example, Sigmoidal curves are normally used to fit dose response data and Hyperbolic
functions are normally used to fit ligand binding data in the field of enzyme kinetics.

If you do not know what type of curve fit to use, you may be able to ask a colleague or do some research to
see what curve fits are normally used with the type of data that you have collected. If that proves to be
fruitless or if nothing is known about the data, then the selection of the model must be based on the raw data.

You can use a Scatter plot to plot the data and see the general shape of the curve. The following figures
provide a glimpse of the general shape associated with some of the more common families of General curve
fits that are used in KaleidaGraph. Within each family, KaleidaGraph provides a number of different curve
fit equations and it may take some trial and error to find the equation that produces the best results.

6
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General Shape of Various Curve Fit Families

Peak Sigmoidal Hyperbola
Exponential Rise Exponential Growth Exponential Decay
Power Waveform
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Using Least Squares Curve Fits

Chapter 2

This chapter provides information on the five Least Squares curve fits available in KaleidaGraph and
includes an example of applying a Polynomial curve fit to a plot.

2.1 KaleidaGraph’s Least Squares Curve Fits

2.1.1 Linear

This function fits a straight line through your data, of the form y =m0 + m1 * x. There are no data restrictions
associated with this curve fit.

Note: On a semi-log or log-log plot, this fit appears as a curved line.

2.1.2 Polynomial

This function fits a curve through your data, of the form y=mO + m1 * x + m2 * X2 +m3* x> +.4+m9 *x°.
The more complex the curvature of the data, the higher the polynomial order required to fit it. There are no
data restrictions associated with this curve fit.

2.1.3 Exponential

This function fits a curve through your data, of the form y =m0 * e™ X It is generally used to fit data that
increases or decreases at a high rate. This curve fit cannot fit negative data or data equal to zero.

Note: On a semi-log plot with a linear X axis, the curve appears as a straight line.

2.1.4 Logarithmic

This function fits a curve through your data, of the form y = m0 + m1 * log(x). A logarithmic curve fit is

generally used with data that spans decades (10°, 10", 102, and so on). This curve fit cannot be used to fit
negative data or data equal to zero.

Note: On a semi-log plot with a linear Y axis, the curve appears as a straight line.

2.1.5 Power

This function fits a curve through your data, of the form y = m0 * x™! This curve fit cannot be used to fit
negative data or data equal to zero.

Note: On a log-log plot, the curve appears as a straight line.

2.1 KaleidaGraph’s Least Squares Curve Fits 9
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2.2 Applying a Least Squares Fit

The following steps explain how to apply a Least Squares fit, using the Polynomial curve fit as an example.
The procedure is basically the same for applying the other Least Square fits. Example 2 in the KaleidaGraph
Quick Start Guide shows how to apply a Linear curve fit to a Scatter plot.

To apply a Polynomial curve fit:

1. Open the plot window which will have the curve fit applied. Figure 2-1 shows a sample plot.

—O— Sinc(5x)

1 L
0.8 ¢
0.6
0.4 —
02

0-
-0.2 —
-0.4 | | 1 1 | 1 |
2 15 -1 05 0 05 1 15 2

-1t/2 to /2

Figure 2-1 Sample plot

Sinc(5x)

2. Choose Curve Fit > Polynomial. A Curve Fit Selections dialog similar to Figure 2-2 appears. All
dependent variables are listed under Column Names.

% Curve Fit Selections |

YView  Column Mames

[] Sinc(5x —

Deszelect |

Cancel

Figure 2-2 Curve Fit Selections dialog
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3. Click the check box for each variable to be fit. A keyboard shortcut (Ctrl+A under Windows or
38 +A on a Macintosh) is available to select all of the variables at once. Each time a variable is
selected, a second dialog appears (Figure 2-3). Use this dialog to specify the order of the
polynomial to be fit. The maximum value that can be selected is nine.

Note: This extra dialog is only displayed when using the Polynomial fit.

% polynomial Order |
Less Moare

Farar =
Cancel |

Figure 2-3 Polynomial Order dialog

4. Click OK to exit each dialog and apply the curve fit.

After the curve fit is applied, you can display its equation or extrapolate the fit to the axis limits.
These are a few of the features covered in Chapter 6 of this guide. Figure 2-4 shows the sample

plot after applying a Polynomial curve fit (represented by the dashed line) and displaying the
equation.

—O— Sinc(5x)

Y = MO + M1*x + ... M8*x® + M9*x°

MO 0.74498

M1 -2.2335e-06

M2 -1.5263

M3 5.3462e-06

M4 0.57926

M5 -2.3478e-06

oL R 0.89451

04—ttt

[
-2 15 1 -05 0 05 1 15 2
-n/2 to /2

Figure 2-4 Sample plot with Polynomial curve fit applied
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Using Nonlinear Curve Fits

Chapter 3

This chapter provides information on the nonlinear curve fit available in KaleidaGraph. It also covers some
basic concepts, including:

e Structuring the curve fit definition and initial guesses.
e Managing the master curve fit list.

*  Using the predefined curve fit equations.

*  Entering a custom curve fit definition.

*  Applying a General curve fit.

e Using weights when applying a General curve fit.

3.1 Introduction to the General Curve Fit

This is the most powerful curve fit in KaleidaGraph. It takes a user-defined equation and uses it to fit a set
of plotted data. Any function of x or m0, where either x or m0 is the independent variable, can be defined
using up to nine parameters (m1-m9).

Examples:
ml * mO
ml + m2 * mO
ml * exp(—m2 * m0)

When a General curve fit is selected, a curve, defined by the equation in the Curve Fit Definition dialog, is
fitted to the data using the Levenberg-Marquardt algorithm. There are no data restrictions associated with
this curve fit.

3.1 Introduction to the General Curve Fit 13
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3.2 General Curve Fit Basics

This section explains the structure of the curve fit equation, setting initial conditions for the parameters, the
Curve Fit Definition dialog, and the use of the commands in the General submenu.

3.2.1 Curve Fit Definition

The curve fit definition is the equation that is fitted to the data. Curve fit definitions are composed of the
same items as formulas in Formula Entry: operators, parameters, functions, and constants, in addition to an
independent variable. When entering the curve fit definition, follow these guidelines:

The independent variable in an equation is represented by m0.

The parameters being calculated by the fit are represented by m1-m9. Parameters should be
entered wherever you have an unknown quantity and you want KaleidaGraph to calculate the best
value.

Use an asterisk (*) for multiplication and a caret (*) for raising quantities to a power.
KaleidaGraph does not distinguish between upper and lower case letters (m0 and MO are the same).

Constants and other shorthand references can be defined in the library for use in a curve fit
definition. Some definitions in the default library are used to substitute x for m0, and a, b, c,and d
for m1, m2, m3, and m4, respectively.

To include a column number as part of the curve fit definition, the table function must be used.
Section 3.3.5 shows how to use the table function in a General curve fit definition. This method
also enables you to fit equations containing multiple independent variables.

The following table lists some equations and how they appear as curve fit definitions in KaleidaGraph.

Original Equations Curve Fit Definitions
a*x+b ml * m0 + m2
a+b*x/c ml + m2 * m0*m3
a+b*exp(— * x) ml + m2 * exp(—m3 * m0)
a * exp(-b * x) * cos(c * x + d) ml * exp(—m2 * m0) * cos(m3 * m0 + m4)

14
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3.2.2 Initial Conditions

Even though KaleidaGraph calculates values for unknown parameters, you must supply an initial value for
each parameter. The algorithm used to calculate the final results requires a reasonable guess to point it in the
right direction. KaleidaGraph improves upon these values during each iteration of the fit.

Note: Since the fit starts with initial guesses and improves upon them with each iteration, the final values
may be different for a separate set of initial guesses.

Do not get carried away trying to find good guesses; the initial conditions are just that, guesses. If you are
not sure what the guesses should be, keep the initial conditions non-zero, and at the correct order of
magnitude that you might expect (be it 0.001, 1, or 1000).

The initial conditions are entered immediately following the curve fit definition. Place a semicolon at the
end of the definition and begin entering the initial guesses, separating each with a semicolon. The table
below shows the definitions from the previous section with some sample initial guesses.

Curve Fit Definitions with Initial Guesses

ml *m0 +m2; ml =0.5; m2 =23

ml +m2 *m0*m3;ml=-2;m2=3;m3=2

ml + m2 * exp(-m3 * m0); ml =5;m2=1; m3=0.5

ml * exp(-m2 * m0) * cos(m3 * m0 + m4); ml =4; m2=0.7,m3=22; m4=15

3.2.3 Curve Fit Definition Dialog

The Curve Fit Definition dialog is used to enter the equation, initial guesses, and allowable error to be used
in the curve fit. You can also choose to specify partial derivatives or to weight the data.

This dialog can be displayed using either of the following methods:

*  Choose a curve fit from the General submenu (Curve Fit menu). In the dialog that is displayed,
click Define.

e Choose Curve Fit > Edit General. In the dialog that is displayed, select the name of a curve fit
and click Edit.

3.2 General Curve Fit Basics 15
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The various features of the Curve Fit Definition dialog are discussed below.

¥ General Curve Fit Definition x|
General Curve Fit for v = F [MO; 7, M2, M3, T i# [eq O Rad ]
1 +m2 MOl =1:m2 =1 6
2 /
3 Allawahle Errar: \I'I & Help... File. .. 7
4 L N _
—F Specify Partials [ wWeight Data ar. Cancel

Figure 3-1 Curve Fit Definition dialog

Text Field
Curve fit definitions and initial guesses are entered in this area of the dialog.

Allowable Error:
The value entered in this field helps KaleidaGraph determine when to stop iterating. Iterations stop if
either of the following occurs:

e Chi Square does not change for a certain number of iterations.

e The percent change in the normalized Chi Square is less than the Allowable Error.

Weight Data

When selected, you can specify a data column that contains weights for the variable you are fitting.
These weights should represent the individual errors of the data values. Each weight is used internally
as:

1/(weight”2). The smaller the error value, the larger the internal weight. If this check box is not selected,
a weight value of 1.0 is used for all data points.

Specify Partials

The algorithm that KaleidaGraph uses in calculating each iteration of the General curve fit requires
evaluating the partial derivative of the function with respect to each parameter. If Specify Partials is
not selected, KaleidaGraph numerically approximates the derivative. If this option is selected, the
dialog expands, as shown in Figure 3-2.

16
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"f’ General Curve Fit Definition E[

General Curve Fit fary' = F [MO; M1, M2, M3, ) @ Deq O Rad

ml +m2 *M0:ml =1 m2=1

Allowwable Error: |'I A Help... File...
v Specify Partials [~ weight Data ]S Cancel
Parameter Partial Dervative:

1

dEAdr T = dF/dk 2 = dF/dk 3 = dF/dk 4 = dF/dk5 =
dF/dME = dF/dk ¥ = dF/dk3 = dF/dk3 =

Figure 3-2 Expanded Curve Fit Definition dialog

The nine buttons at the bottom of the dialog allow each partial derivative to be entered in the text field
above the buttons. The biggest advantage of specifying the partial derivatives is accuracy. The curve fit
algorithm uses these partial derivatives to direct itself where to move after each iteration to find the best
solution.

You can choose to specify only some of the partial derivatives, but not all of them. It is better to let
KaleidaGraph approximate the partial instead of specifying the wrong derivative. If a partial derivative
is missing, KaleidaGraph numerically approximates that partial derivative.

5. Degrees/Radians Buttons
These buttons determine whether the results of trigonometric functions are in degrees or radians.

6. Help...
Click this button to display the Help dialog.

7. File...
Clicking this button displays a text editor that can be used to create, open, or save a curve fit definition.
The definition appears on the first line and any partial derivatives appear on the lines below it.

3.2 General Curve Fit Basics 17
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3.2.4 Managing the Curve Fit List

KaleidaGraph maintains a master list of curve fits in the General submenu. This submenu can store up to
16 user-defined equations that can be applied whenever a new plot is created.

The following sections explain how to edit and save changes to the curve fits listed in the General submenu.

Note: The only way to edit the master list is to create a new plot and use the Edit General command. The
master list is not affected if you do either of the following:

e Use a saved plot (or any plot that had its data archived).

e  Choose a curve fit from the General submenu and click Define to edit the definition.

Adding a Curve Fit to the Master List
To add a curve fit to the master curve fit list:

1. Create a new plot.

2. Choose Curve Fit > General > Edit General. The dialog in Figure 3-3 appears.

x
fitl af << Replace " Cliphoard
<< Add " Trazh
Copyss
Hemoye
_E Edit -
ak. Cancel

Figure 3-3 Edit General dialog
Select a fit in the current list.

4. Click Add and a New Fit appears below the selected fit in the list. The name of the fit can be
changed by selecting it and editing the name in the text field.

5. Click Edit to enter the definition in the Curve Fit Definition dialog.

6. Click OK when you are finished. Now you can use this fit in the active plot or any new plots that
are created. Remember to save changes to the Macros file to make the changes permanent.

18
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Rearranging the Master Curve Fit List
To rearrange the curve fit list:
1. Create a new plot.
Choose Curve Fit > General > Edit General.
Select the curve fit to be repositioned.
Click Copy to copy the fit to the trash bin.
Click Remove to delete the name from the listing.
Select a curve fit in the current list.

Select the name of the curve fit that was copied to the trash bin.

0 N9 N L AW

Click Add and the curve fit appears below the selected fit in the list.

Note: When rearranging curve fits, do not leave the Edit General dialog until you are completely finished.
As soon as you click OK or Cancel in this dialog, anything in the trash bin is deleted. The only
permanent trash bin item is New Fit.

Removing a Curve Fit from the Master List
To remove a curve fit from the master list:

Create a new plot.

Choose Curve Fit > General > Edit General.

1

2

3. Select the curve fit to be deleted.

4. Click Remove to delete the curve fit from the listing.
5

Click OK.

3.2 General Curve Fit Basics 19
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Adding Curve Fits from the Master List to Saved Plots

When a saved plot is opened, the General submenu displays the curve fits that were available when the plot
was originally created, regardless of what is currently in the master list. To add curve fits from the master
curve fit list to a saved plot:

1. Open a saved plot.

Choose Curve Fit > General > Edit General. The curve fits stored in the master list appear below
the dotted line in the trash bin.

Select the name of the curve fit to be added from the trash bin listing.
Select a fit in the current list.

Click Add and the curve fit appears below the selected fit in the list.

N L B~ W

Click OK when you are finished. Now you can use this fit in the saved plot.

Saving Changes to the Curve Fit Menu

The curve fits in the General submenu are saved, by default, in a file called KG Macros. This file is loaded
each time you start KaleidaGraph.

To save any changes made to the Curve Fit menu, it is necessary to save the changes to the default Macros
file using one of the following methods:

* In the Preferences dialog, select Prompt from the Macros pop-up menu. When exiting
KaleidaGraph, a dialog asks whether or not to overwrite the Macros file that was opened at launch.

e In the Preferences dialog, select Always from the Macros pop-up menu. When exiting
KaleidaGraph, the Macros file that was opened at launch is automatically overwritten.

e Choose File > Export > Macros and overwrite the default Macros file.

Note: Only changes made to a new plot using the Edit General command are saved as part of the macros
file. Any changes made to a saved plot or by choosing a curve fit from the General submenu and
clicking Define apply solely to that particular plot.

20
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3.3 Using the General Curve Fit

This section explains how to define and apply a General curve fit equation. Other topics include weighting
data, limiting parameters, and defining equations in the library. If you are new to using the General curve

fit, refer to Section 3.2 which covers some basic concepts, including equation structure, initial conditions,
the Curve Fit Definition dialog, and managing the curve fit list in the General submenu.

3.3.1 Using the Predefined Curve Fit Definitions

KaleidaGraph includes over 100 curve fit definitions that are divided into several categories (Polynomial,
Logarithmic, Sigmoidal, and so on). These curve fit definitions are provided in the following formats for use
in KaleidaGraph:

o  Each curve fit definition is stored as a text file in the Curve Fits folder.

e Each category of definitions is stored as a Macros file that can be imported to load the definitions
into the General submenu.

*  Each category of definitions is stored as a text file for use in the Library.

Importing Definitions from a Text File

The Curve Fits folder contains each curve fit definition as a text file. This allows you to import specific
curve fit definitions for use in KaleidaGraph.

To load a text file containing a curve fit definition (and have it available for all future plots):

1. Create a new plot.

2. Choose Curve Fit > General > Edit General. The dialog in Figure 3-4 appears.

x
fitl af << Replace " Cliphoard
<< Add " Trazh
Copyss
Hemoye
_E Edit -
ak. Cancel

Figure 3-4 Edit General dialog
3. Select a fit in the current list.

4. Click Add and a New Fit appears below the selected fit in the list. The name of the fit can be
changed by selecting it and editing the name in the text field.

3.3 Using the General Curve Fit 21
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Click Edit to display the Curve Fit Definition dialog.

5
6. Click File in the Curve Fit Definition dialog. A text editor appears.
7. Choose File > Open.

8

Locate and open a curve fit definition from the Curve Fits folder. The definition and initial guesses
for the parameters will be displayed in the editor.

9. Choose File > Close to display the curve fit equation in the Curve Fit Definition dialog. Make sure
you change the initial guesses, because all of the initial guesses are set equal to 1.0 by default.

10. Click OK until you return to the plot window. Now you can use this fit in the active plot or any
new plots that are created. Remember to save changes to the Macros file to make the changes
permanent.

Importing Definitions from a Macros File

The Macros folder contains a Macros file for each category of curve fit definitions. Importing one of these
Macros files loads the curve fit definitions into the General submenu.

Note: If a plotis already open, you will not see the imported curve fit definitions until a new plot is created.

To load the definitions from a Macros file:

1. Choose File > Open.
2. Locate and open the Macros file of interest from the Macros folder.

3. Create a new plot. The curve fit definitions stored in the Macros file will be listed under the
General submenu.

4. Youcannow apply one of these fits to your data. Make sure you change the initial guesses, because
all of the initial guesses are set equal to 1.0 by default.

Importing Definitions into the Library

The Library folder contains text files for each category of curve fit definitions. These text files can be
loaded into the library for use in the General curve fit.

To load a text file into the library:

1. Choose Macros > Library or Curve Fit > General > Library.

2. Choose File > Open.

3. Locate and open the curve fit category of interest from the Library folder.
4

Browse through the library and make note of the shorthand reference and number of unknowns for
the curve fits that you will be using.

5. Choose File > Close.

You can now use these library definitions to apply a General curve fit. When entering the definition in the
Curve Fit Definition dialog, you can enter the shorthand reference defined in the library with the initial
guesses, for example gaussfit(1,5,1,10). KaleidaGraph will perform the necessary substitutions before
applying the fit.
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3.3.2 Entering a Custom Curve Fit Definition

If you need to use a curve fit equation that is not included with the predefined equations, you can easily enter
a custom equation and use it in KaleidaGraph.

Note: Custom curve fit equations can also be defined in the library. Refer to the KaleidaGraph manual or

online help for more information.

To create a custom curve fit definition (and have it available for all future plots):

1
2
3.
4

9

"f’ General Curve Fit Definition E[

General Curve Fit fary' = F [MO; M1, M2, M3, ) @ Deq O Rad

Create a new plot.
Choose Curve Fit > General > Edit General.
Select a fit in the current list.

Click Add and a New Fit appears below the selected fit in the list. The name of the fit can be
changed by selecting it and editing the name in the text field.

Click Edit to display the Curve Fit Definition dialog.

Enter the curve fit equation in the Curve Fit Definition dialog. Make sure you include the initial
guesses for each of the unknown parameters. Figure 3-5 shows an example curve fit equation and
its initial guesses.

&llawwable Ermar: I-I

[ Specify Partials [ weight Data k. Cancel

m1+m2*exp(-[m0-m3m0-m3)md* md]:m1=1:m2=5m3=1md=10;

el

Help... File...

7.

Figure 3-5 Example curve fit equation

Click OK until you return to the plot window. Now you can use this fit in the active plot or any
new plots that are created. Remember to save changes to the Macros file to make the changes
permanent.
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3.3.3 Applying a General Curve Fit

To apply a General curve fit:

1. Open the plot window which will have the curve fit applied. Figure 3-6 shows a sample plot.
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Figure 3-6 Sample plot

2. Choose a curve fit from the General submenu (Curve Fit menu). A Curve Fit Selections dialog
similar to Figure 3-7 appears. All dependent variables are listed under Column Names.

% Curve Fit Selections |
_ Define...
Wiew  Column Mames
] E —
Deszelect | Cancel

Figure 3-7 Curve Fit Selections dialog

3. If the equation has not been entered, click Define to enter the equation or shorthand reference to
be applied to the data. Figure 3-8 shows the Curve Fit Definition dialog containing a curve fit
definition. When you are finished, click OK.

Note: For information on including this fit in your master curve fit list, refer to Section 3.2 4.
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"f’ General Curve Fit Definition E[

General Curve Fit fary' = F [MO; M1, M2, M3, ) @ Deq O Rad

m1+m2*exp(-[m0-m3m0-m3)md* md]:m1=1:m2=5m3=1md=10;

&llawwable Ermar: I-I

o

Help... File...

[ Specify Partials [ weight Data akK Cancel

Figure 3-8 Curve Fit Definition dialog

4. Click the check box of each variable to be fit. Typing Ctrl+A (Windows) or 3+A (Macintosh)
selects all of the variables at once.

5. Click OK to apply the curve fit. A status dialog will show the progress of the curve fit. It is updated
after each iteration.

Note: Typing Ctrl+Period (Windows) or 38 +Period (Macintosh) cancels a General curve fit.
The current state of the fit is calculated and the resulting curve is drawn.

When the curve fitting process is complete, the curve is drawn on the plot. Once the curve fit is
applied, you can display its equation or extrapolate the fit to the axis limits. These are a few of the
features covered in Chapter 6 of this guide. Figure 3-9 shows the sample plot after applying a
General curve fit (represented by the dashed line) and displaying the equation.

oBI Data 1
y = m1 + m2*exp(-(m0-m3)*(mO...
16 L Value Error
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12 D gy m3 | 3.3389e-11| 7.1266e-08
- / \ m4 20| 1.2765e-07
10+ @ & Chisq | 4.2923e-12 NA
- ! ' R 1 NA
8 o o)
~ \
T
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4
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Figure 3-9 Sample plot with General curve fit applied
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3.3.4 Weighting Data

The General curve fit provides an option to weight the data. When Weight Data is selected in the Curve Fit
Definition dialog, the data is weighted during the curve fit. These weights are taken from a specified column
in the data window. The weights should represent the individual error values of the fitted data.

Each weight is used internally as: 1/(weight/2). Specifying a weight less than 1.0 for a data point increases
the internal weight of that point and can make the total error much larger. Weight values larger than 1.0
reduce the internal weights. When Weight Data is not selected, a weight value of 1.0 is used for all data
points.

When the Weight Data option is selected and you choose a variable to fit, the dialog in Figure 3-10 appears.
Use this dialog to select the column containing the weights for your data.

% weighted Curve Fit |

Wieight Drata From Colurmr:

ak. Cancel

Figure 3-10 Selecting column of weights

3.3.5 Fitting Equations with Multiple Independent Variables

Through the use of the table function, KaleidaGraph can fit equations containing multiple independent
variables. For example, to fit an equation like y = a*x + b*x2 +c, you would enter the following curve fit
definition: a*x + b*table(m0, x col, x2 col) + ¢. You need to replace x col and x2 col with the appropriate
column numbers from the data window (for example, table(m0, c0, c2)). The result of using the table
function is that for each value of x, the corresponding value from the x2 column is evaluated as part of the
curve fit.
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3.3.6 Setting Limits for Curve Fit Parameters

Limits on curve fit parameters can be set in one of two ways. The first method is to use conditional testing
on the parameter. The second method is to use the limit function from the default library.

Suppose that a General curve fit is being defined to fit a straight line to a set of data. The equation is of the
form: a+b*x. In this example, you want to limit the value of b so that it is not a negative number.

In the Curve Fit Definition dialog, enter either of the following definitions:
a+ (b=(b<0)? 0:b) *x; a=1;b=1 or a+ (b=limit(0, 1000, b))*x; a=1; b=1

In the first definition, a conditional test is performed to see if b is less than zero. If true, b is set to zero; if
false, b is set equal to itself.

In the second definition, the limit function is used. The limit function requires that a lower and upper
boundary be set for the parameter. In this case, zero and 1000 are used to bound the extremes of b.

Whenever a parameter is bound in a General curve fit definition, you must specify partial derivatives.
Otherwise, a Singular Coefficient Matrix error may occur if the parameter being limited gets pegged at a
bounding point for multiple iterations.

3.3.7 The General Curve Fit and the Macro Calculator

Calculations for the General curve fit are performed in the Macro Calculator. After performing a General
curve fit, the memory registers in the Macro Calculator store information about the fit. The memory registers
and their contents are listed below:

m0 R value

ml-m9 The values of the parameters.
m?22 Chi Square value

m?23 % error term

m24 Chi Square of the last iteration.
m25 Number of iterations completed.
m26 Number of parameters in the fit.

Note: Almost all memory registers, alpha registers, and program space are overwritten during the
execution of a General curve fit.
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Chapter 4

This chapter provides information on the four smoothing curve fits available in KaleidaGraph and includes
an example of applying a Cubic Spline curve fit to a plot.

4.1 KaleidaGraph’s Smooth Curve Fits

4.1.1 Smooth

This function fits a smoothed curve to the data. KaleidaGraph starts by applying a Stineman function to the
data. The output of this function then has a geometric weight applied to the current point and +10% of the
data range, to arrive at the smoothed curve.

The only data restriction associated with this curve fit is that the independent (X) variable must be in
ascending order in the data window. There is no single expression that represents this curve; therefore, there
are no parameters to view or copy.

4.1.2 Weighted

This function fits a curve to the data, using the locally weighted Least Squared error (Lowess) method. The
result of this curve fit is to plot a best fit smooth curve through the center of the data. This is an extremely
robust fitting technique. Unlike the standard Least Squared error method, this technique is nearly insensitive
to outliers. However, this does not come for free. The Weighted curve fit is computationally complex and
can take a very long time for a large data set.

The only data restriction associated with this curve fit is that the independent (X) variable must be in
ascending order in the data window. There is no single expression that represents this curve; therefore, there
are no parameters to view or copy.

4.1.3 Cubic Spline

Moving left to right along the curve in increasing X, every group of four consecutive data points defines a
cubic polynomial equation. A series of these cubic polynomials connected together define a cubic spline
curve. Using this curve fit is similar to using a French curve to connect all of the data points.

The only data restriction associated with this curve fit is that the independent (X) variable must be in
ascending order in the data window. There is no single expression that represents this curve; therefore, there
are no parameters to view or copy.
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4.1.4 Interpolate

This function fits a curve that passes through the data points and matches the slopes at those points. The
advantage of this curve fit is that it does not produce wild results near an abrupt change of slope, as can
happen with the Cubic Spline curve fit.

The only data restriction associated with this curve fit is that the independent (X) variable must be in

ascending order in the data window. There is no single expression that represents this curve; therefore, there
are no parameters to view or copy.

4.2 Applying a Smoothing Fit

The following steps explain how to apply a smoothing fit, using the Cubic Spline curve fit as an example.
The procedure is basically the same for applying the other smoothing fits.

To apply a Cubic Spline curve fit:

1. Open the plot window which will have the curve fit applied. Figure 4-1 shows a sample plot.
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Figure 4-1 Sample plot

2. Choose Curve Fit > Cubic Spline. A Curve Fit Selections dialog similar to Figure 4-2 appears.
All dependent variables are listed under Column Names.

% Curve Fit Selections |

YView  Column Mames

[ Test#1 —
[ Test#tz2 -

Cancel |

Figure 4-2 Curve Fit Selections dialog

Deszelect |
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Click the check box for each variable to be fit. A keyboard shortcut (Ctrl+A under Windows or
38 +A on a Macintosh) is available to select all of the variables at once.

Note: When applying a Weighted fit, a second dialog appears each time a variable is selected. Use
this dialog to specify the smoothing factor.

Click OK to apply the curve fit.

Note: If an error message appears saying the data needs to be sorted, you will need to use the
Ascending Sort command from the Data menu. Once the independent variable is sorted,
the curve fit can be applied.

After the curve fit is applied, you can increase the number of curve fit points or hide the original
data to only display the curve fit. These are a few of the features covered in Chapter 6 of this guide.
Figure 4-3 shows the sample plot after applying a Cubic Spline curve fit (represented by the solid
line).
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Figure 4-3 Sample plot with Cubic Spline curve fit applied
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Chapter 5

This chapter explains how to:

e View the results of a curve fit.

* Interpret the values that are reported by KaleidaGraph.
*  Export the curve fit results for further analysis.

e Obtain values from the curve fit line using Formula Entry.

5.1 Viewing Curve Fit Results

5.1.1

KaleidaGraph provides two methods to view the results of a curve fit. You can either display the equation
on the plot or view the coefficients in a dialog.

Displaying the Curve Fit Equation

The curve fit equation can be displayed by turning on Display Equation in the Plot menu. The results from
any General, Linear, Polynomial, Exponential, Logarithmic, or Power curve fits are displayed in the plot
window. Not only is the resulting equation displayed, but if any updates occur to the curve fit, the equation
updates automatically.

Depending on the type of curve fit, the equation is displayed in a table or as a text label. The General and
Polynomial curve fits display equations in a table because the equations for these fits can be much longer
than the others. The appearance of the equation can be edited by double-clicking it with the Selection Arrow.

The numeric format of the equation can be controlled using the Equation Label Format command (Format
menu). Some of the options available include number format, number of significant digits, and trailing zeros.
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5.1.2 Viewing Coefficients

The other method of displaying curve fit results is to view the curve fit’s coefficients in a dialog.

To view the coefficients from the curve fit:

1. Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog similar to Figure 5-1
appears with a drop-down arrow under View for each variable that has a curve fit applied.

% Curve Fit Selections |

YView  Column Mames

[w] [ Test# -
(w] [ Test#? -

Cancel |

Figure 5-1 Curve Fit Selections dialog

Deszelect |

2. Click one of the drop-down arrows and choose View Results from the pop-up menu that appears.
A dialog similar to Figure 5-2 will be displayed containing the coefficients from the curve fit.

“ Fit Results X|

Linear Coefficients:

= W0+ W1

h0 5.3556

1 -0.26544
K 0.55304

Copy to ..

£ [ ||| || ||=|Lﬁ'!' 1 F-!'."-F- |P|l|]'|i‘|r =|[1'i_l |1.IF.'| i

Figure 5-2 Viewing coefficients

3. To copy the coefficients to the Clipboard, click Clipboard. This enables you to paste the results
into another window or program.

4. To copy the coefficients to the Calculator, click Calculator. This enables you to use the results in
a Formula Entry function.

5. Click OK until you return to the plot window.
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5.2 Interpreting Curve Fit Results

This section explains some of the values that are calculated when using the General, Linear, Polynomial,
Exponential, Logarithmic, and Power curve fits. The correlation coefficient is calculated for each of these
fits, but only the General curve fit displays the parameter errors and Chi Square value.

5.2.1 Correlation Coefficients
A correlation coefficient (R or R?) is displayed with the curve fit’s equation and coefficients. The correlation

coefficient indicates how well the calculated curve fits the original data.

This value ranges from zero to one. The closer to one, the better the fit. The equation used to calculate the
correlation coefficient is listed in Section B .2.

You can choose to display the Linear Correlation Coefficient (R) or the Coefficient of Determination (Rz)
as part of the results. The Display RA2 instead of R check box in the Curve Fit Options dialog (Format
menu) controls which is displayed.

5.2.2 Parameter Errors

The General curve fit displays a column of errors to the right of the parameter values. The errors represent
the standard error values of the parameters. These values should be read as: parameter value + error.

5.2.3 Chi Square Value

The General curve fit reports a Chi Square value as part of the results. This value is the sum of the squared
error between the original data and the calculated curve fit. In general, the lower the Chi Square value, the
better the fit. The equation used to calculate Chi Square is listed in Section B.2.
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5.3 Exporting Curve Fit Results

Once a curve fit has been applied, the results of the fit can be exported for further analysis. The export
options include copying the parameter values to the Clipboard or the Calculator, copying the values of the
curve fit line into the data window, and copying the residual values into the data window.

5.3.1 Copying the Parameters to the Clipboard or Calculator
To copy the parameter values to the Clipboard or Calculator:

1. Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog similar to Figure 5-3
appears with a drop-down arrow under View for each variable that has a curve fit applied.

% Curve Fit Selections |

YView  Column Mames

[w] [ Test# -
(w] [ Test#? -

Cancel |

Figure 5-3 Curve Fit Selections dialog

Deszelect |

2. To copy the coefficients to the Clipboard, click one of the drop-down arrows and choose Copy
Parameters to Clipboard from the pop-up menu that appears. This enables you to paste the results
into another window or program.

Note: If you paste the results into the plot window, the coefficients in the table do not change if
the curve fit is updated. For this reason, we recommend that you use the Display Equation
command instead.

3. To copy the coefficients to the Calculator, click one of the drop-down arrows and choose Copy
Parameters to Calculator from the pop-up menu that appears. This enables you to use the results
in a Formula Entry function.

4. Click OK to return to the plot window.

Note: It is also possible to copy the parameters by choosing View Results from the pop-up menu and
clicking the Clipboard or Calculator button.
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5.3.2 Copying the Curve Fit Values to the Data Window

To copy the values of the curve fit line to the data window:

1. Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog similar to Figure 5-3
appears with a drop-down arrow under View for each variable that has a curve fit applied.

2. Click one of the drop-down arrows and choose Copy Curve Fit to Data Window from the pop-
up menu that appears.

3. Click OK to return to the plot window.

KaleidaGraph will append the results after any existing data in your data window. The first column will be
a series of X values. Except for the Weighted curve fit which uses the original X values, the number of X
values will be equal to the number of curve fit points specified in the Curve Fit Options dialog (Format
menu). The second column will contain the values from the curve fit at each of these locations.

Note: If you want to use the original X values or supply your own X values, you need to use Formula Entry
to calculate the curve fit values. Section 5.4 provides instructions for using the curve fit functions in
Formula Entry to obtain values from the curve fit.

5.3.3 Copying the Residuals to the Data Window

To copy the residual values to the data window:

1. Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog similar to Figure 5-3
appears with a drop-down arrow under View for each variable that has a curve fit applied.

2. Click one of the drop-down arrows and choose Copy Residuals to Data Window from the pop-
up menu that appears.

3. Click OK to return to the plot window.

KaleidaGraph will append the residual values after any existing data in the data window. These values
represent the difference between the original Y values and the values calculated by the curve fit.
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To calculate values from a curve fit:

1. Activate the data window that contains the fitted variables. Figure 5-5 shows a portion of the data
used to create the sample plot.

_ioix
= [ 0_J-piztopir[_1_] Sinciso [L2_] c &
0 ~1. 5708 0.12732 - |
1 -1.5391 0.12832 _l

2 -1.5073 0.1lzZa06

3 -1.4756 0.1z047

4 -1.4439 0.11154
5 -1.41Z1 0.099349 -
2 | M 2

Figure 5-5 Data used to create sample plot
2. Choose Windows > Formula Entry.

3. Enter the formula into the window. Figure 5-6 shows the formula for this example. The formula
should be of the form z = fit(x,y), where:

Z is the destination column.

X is either a single data value or a column containing X values.
y is the column that had the curve fit applied.

fit is replaced by the appropriate command from the Curve Fits menu of Formula Entry.

% Formula Entry |
Operators Funchions Statiztics Curve Fits Special Library
c2=paly[c0.c1) ® Deg O Rad

ﬂelp...l
=g f | F2| F3| rFa| Fs| Fe| F7| _F8|[_Bu |

Figure 5-6 Curve fit function entered in Formula Entry

4. Click Run to execute the formula. The destination column is filled with the values of the curve fit

at the specified X values. Figure 5-7 shows the resulting data window, with the curve fit values in
the last column (column 2).
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Figure 5-7 Data window containing curve fit values

Note: This method uses the curve fit points originally calculated when the fit was applied. You may want
to increase the number of calculated points to make the values from the fit more accurate. See
Section 6.5 for instructions on increasing the number of curve fit points.

5.4.2 Using the Calculated Equation to Find Values

The most accurate method of getting values from a fit is to use the original equation and the parameters
calculated by KaleidaGraph. This is not possible when a Smooth, Weighted, Cubic Spline, or Interpolate
curve fit is applied to the data, because these curve fits do not result in an equation.

To calculate values using the curve fit’s equation:

1.

Copy the curve fit coefficients to the Calculator. Refer to Section 5.3.1 if you are unsure of how to

do this. If you applied a General curve fit, you can skip this step because the parameters are
automatically stored in the Calculator.

a column containing new X values (column 2).

HF'pata1

=10 x|

Activate the data window that contains the fitted variables. Figure 5-8 shows the original data with
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2 | M 2

Figure 5-8 Data window containing new X values
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Choose Windows > Formula Entry.

4. Enter your formula into the window. Figure 5-9 shows the formula used to obtain values from a
curve fit at designated points, where:

c3 is the destination column for the curve fit values.
c2 is the column containing the new X values.

mO-mS5 are the curve fit coefficients previously copied to the Calculator.

"'"fr'* Formula Entry
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Functions
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rs Statistics Curve Fits Special Library
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__Help... |
E=f) F1 | F2| F3| Fae| Fs| Fe| F7 | F8|[_Run ]

Figure 5-9 Using the curve fit equation to calculate values

5. Click Run to execute the formula. The destination column is filled with the values of the curve fit

at the specified X values. Figure 5-10 shows the resulting data window, with the curve fit values
in the last column (column 3).
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Figure 5-10 Data window containing curve fit values

Note: This method can similarly be used to calculate the X value when the Y value on the fit is known. You
need to rearrange the formula so that it solves for X instead of Y.

5.4 Using Formula Entry to Obtain Values from a Curve Fit
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Other Curve Fit Features

Chapter 6

This chapter explains how to:

e Change the appearance of the curve fit.

* Display just the curve fit line on the plot.

*  Extrapolate a curve fit to the axis limits.

e Force a Linear fit through the origin.

* Increase the number of curve fit points.

¢ Remove a curve fit.

6.1 Changing Appearance of Curve Fit Lines

To change the line style, width, or color of curve fit lines:

1
2
3.
4

With the plot window active, choose Plot > Plot Style.
Select the variable to be edited.
Click Curve Fit to make changes to the curve fit line.

To change the line style, select a different option from the Style column. Choose None from this
list to hide the line. The current style is preceded by a check mark.

To change the line width, select a different option from the Width column. The current width is
preceded by a check mark.

To change the color, select a different color from the palette. The current color has a white square
around it.

Click OK to return to the plot.
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6.2 Displaying Only the Curve Fit

There may be times when you are only interested in displaying the curve fit on the plot without the original
data points. This can be accomplished using the Plot Style dialog, provided the plot is not a Scatter plot.
To display only the curve fit:

1. With the plot window active, choose Plot > Plot Style. The Plot Style dialog appears.

2. Select the variable to be hidden.

Select None from the Show Markers pop-up menu and None for the Line Style. This hides the
markers and line used to represent the original data.

4. Click OK to return to the plot. The variable is hidden and only the curve fit is displayed.

6.3 Extrapolating to the Axis Limits

Curve fits are normally displayed between the minimum and maximum data values plotted on the
independent axis. However, you can choose to extrapolate the curve fits to the axis limits. The extrapolated
portion of the fit is based on the calculated equation.

Note: Itisnot possible to extrapolate the Smoothing fits (Smooth, Weighted, Cubic Spline, and Interpolate)
because they cannot be represented by a single equation.

To extrapolate a curve fit:

1. Choose Format > Curve Fit Options. The dialog in Figure 6-1 appears.

¥ Curve Fit Dptions |

Curve Fit Points: I'I a0

[~ Display B ™ 2 inztead of B

v Extrapolate Fit to Axis Limits

[T Faorce Line fit through zeno

ak. Cancel

Figure 6-1 Curve Fit Options dialog
2. Select the Extrapolate Fit to Axis Limits check box.

3. Click OK to return to the plot. After recalculating the curve fits, the plot is redrawn to extend the
curve fits to the axis limits.
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6.4 Forcing a Linear Fit Through the Origin

By default, the slope and intercept are calculated when applying a Linear curve fit. KaleidaGraph provides
an option that forces the curve fit to pass through the origin (0,0), so that only the slope of the line is
calculated.

To force a Linear curve fit through the origin:

1. Choose Format > Curve Fit Options.
2. Select the Force Line fit through zero check box.

3. Click OK to return to the plot. Any Linear curve fits are recalculated with a Y-intercept of zero.

6.5 Increasing the Number of Curve Fit Points

Any time a curve fit is applied (except for the Weighted fit), KaleidaGraph calculates a predetermined
number of points along the fit. These points are used to draw the curve fit and calculate values from the fit.
You may find it useful to increase the number of curve fit points when using Formula Entry to place values
from the fit into the data window. This increases the accuracy of these values.

To increase the number of curve fit points:

1. Choose Format > Curve Fit Options.

2. Enter a different value in the Curve Fit Points field. A good starting point is to enter the number
of points that were plotted. You may want to make this value even higher if there are a number of
peaks and valleys in the data.

3. Click OK to return to the plot window and recalculate the fits.
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6.6 Removing a Curve Fit

Curve fits can be removed from a plot in the same way that they are added. After applying a curve fit, a check
mark appears next to that type of fit in the Curve Fit menu to indicate that a curve fit is applied.

To remove a curve fit from the plot:

1. From the Curve Fit menu, choose the type of curve fit to be removed. A dialog similar to
Figure 6-2 is displayed containing the list of variables. The check box of each fitted variable is
selected.

% Curve Fit Selections |

YView  Column Mames

] ] Test -
L] Test #i2

] [ Test#3 -

Deszelect | Cancel |

Figure 6-2 Curve Fit Selections dialog

2. Clear any check boxes for the fits to be removed. Clicking Deselect clears all of the check boxes
at once.

3. Click OK to return to the plot and remove the curve fits and any associated equations.
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Troubleshooting Curve Fit
Problems

Appendix A

Singular Coefficient Matrix error message

KaleidaGraph could not converge on a solution or was getting a divide by zero error in the General curve
fit. Verify that none of the initial guesses are set to 0. Try changing the initial guesses to steer KaleidaGraph
away from whatever caused the error. You can also try to specify the partial derivatives to point
KaleidaGraph in the right direction after each iteration.

The data must be sorted first error message.

This error results when you attempt to apply a Smooth, Weighted, Cubic Spline, or Interpolate curve fit to
data which does not have the independent variable sorted in ascending order. Once the independent variable
is sorted using the Ascending Sort command (Functions menu), the curve fit can be applied.

Syntax Errors

These result when illegal characters or undefined functions are used in a curve fit definition. Some common
mistakes include using the letter o instead of a zero, having a different number of left and right parentheses,
and attempting to call a library function that is not defined in the current library.

Syntax error in the Macro Library error message.
This error results when the library contains an undefined function. These errors commonly result when
opening a saved curve fit definition in the library instead of opening it in the Curve Fit Definition dialog.

To replace the current contents of the Library with the default Macro Library:

1. Select the Library command from either the Macros menu or the Curve Fit menu.
2. Choose File > Open.

3. Locate and open the Library file within the Library folder and open it.

4. Choose File > Exit.
5

After doing this, make sure you save the Macros when quitting KaleidaGraph in order for the
Library to be saved as part of the KG Macros file.

Tried to limit the parameter values, but the resulting parameters were outside of the specified limits.
It is possible to get values outside of the limits. During each iteration, KaleidaGraph tries to improve upon

the parameter values to get the best fit. These new values are not passed through the function to limit their

value. The number you are seeing is KaleidaGraph’s last best guess at what the value should be. Right now,
the only way to avoid this is to replace the unknown with a constant.
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Not getting the correct results when typing the results of a curve fit into a formula.

By default, the results of a curve fit are displayed with five significant digits. You can obtain more accuracy
by choosing Format > Equation Label Format and increasing the number of digits or decimals. This will
make the results of your formula more accurate.

Another solution is to copy the results of the curve fit to the Calculator. These values are always stored as
double precision numbers. See Section 5.3.1 for more information on copying the results to the Calculator.

Linear Fits on Plots with Log or Semi-Log Scales

When applying a Linear curve fit to data displayed on a log-log or semi-log scale, the curve fit may not
appear to be a straight line. This is because the divisions along logarithmic axes are not equally spaced.
However, it is possible to get the appearance of a straight line on plots with either log-log or semi-log scales.

You can get the appearance of a straight line on a plot with a log-log scale (both the X and Y axes are
logarithmic) by applying a Power curve fit to the data. The resulting curve fit will look like a straight line.

Getting the appearance of a straight line on a plot with a semi-log scale (either the X or Y axis is logarithmic)
depends on which axis is logarithmic:

e If the X axis is logarithmic (Y axis is linear), applying a Logarithmic curve fit will result in a
straight line.

e Ifthe Y axis is logarithmic (X axis is linear), applying an Exponential curve fit will result in a
straight line.
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Reference Information

B.1

Appendix B

This chapter provides information on the methods and equations used when performing regression analysis
in KaleidaGraph.

Curve Fit References

General Curve Fit

Press, W. H., Flannery, B. P., Teukolsky, S. A., and Vetterling, W. T. Numerical Recipes in C. Cambridge
University Press, New York (1988).

Linear, Polynomial, Exponential, Logarithmic, and Power Curve Fits
Beyer, W. H. Standard Mathematical Tables. CRC Press, Cleveland (1976).

Smooth Curve Fit
Stineman, R. W. A consistently well-behaved method of interpolation. Creative Computing, July (1980).

Weighted Curve Fit

Chambers, J. M., Cleveland, W. S., Kleiner, B., and Tukey, P. A. Graphical Methods for Data Analysis.
Duxbury Press, Boston (1983).

Cubic Spline Curve Fit

Press, W. H., Flannery, B. P., Teukolsky, S. A., and Vetterling, W. T. Numerical Recipes in C. Cambridge
University Press, New York (1988).

Interpolate Curve Fit
Stineman, R. W. A consistently well-behaved method of interpolation. Creative Computing, July (1980).
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B.2 Pearson’s R and Chi Square Equations

2 .
%~ = Chi Square y; = actual value x; = calculated Y fit value

o; = weight y = mean of actual values X = mean of calculated Y fit values

Pearson’s R (Least Squares curve fits)

E(xi—i)(yi—y)

Jg (lx,.—x>2 @@,—W

R =

Pearson’s R (General curve fit)

2
R= |1— X—_
Eﬁi(yi—y)z
l

Chi Square

=305

1 l

50 B.2 Pearson’s R and Chi Square Equations



Index

A

adding
curve fits to Curve Fit menu 18
curve fits to saved plots 20
Allowable Error field 16
applying
Cubic Spline curve fit 30-31
General curve fit 24-25
Polynomial curve fit 10—11

C

calculating curve fit values 38—41
canceling a General curve fit 25
Chi Square 35
Chi Square equation 35, 50
Coefficient of Determination 35
color

curve fit 43

variable 43
constraining parameters 27
copying

curve fit coefficients 34, 36

curve fit values to data window 37

residuals to data window 37
correlation coefficients 35
Cubic Spline curve fit

applying 30-31

data restrictions 29

description 29

reference 49
curve fit coefficients 34, 36
curve fit definition

constructing 14

entering custom equation 23

importing 21-22

initial conditions 15

multiple independent variables 26

predefined equations 21-22
Curve Fit Definition dialog 15
curve fit equations

correlation coefficient display 35
displaying 33
editing 33

Curve Fit menu

adding a new fit 18
rearranging curve fits 19
removing curve fit definitions 19
saving changes 20
Curve Fit Options command 44—-45
Curve Fit Points field 45
curve fit results
Chi Square 35
copying fit values to data window 37
copying residuals to data window 37
copying to Calculator 36
copying to Clipboard 36
correlation coefficients 35
displaying the equation 33
editing the equation 33
parameter errors 35
viewing coefficients 34
curve fit types
Cubic Spline 29
Exponential 9
General 13
Interpolate 30
Linear 9
Logarithmic 9
Polynomial 9
Power 9
Smooth 29
Weighted 29
curve fits
applying 10, 24, 30
color 43
displaying equation 33
displaying only the curve fit 44
editing resulting equation 33
exporting results 36—-37
extrapolating 43
forcing fit through the origin 45
getting values from 38—41
increasing curve fit points 45
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limiting parameters 27

line style 43

line width 43

multiple independent variables 26
removing 46

viewing coefficients 34

weighting data 26

D

data windows

copying curve fit values into 37

copying residuals into 37
defining custom curve fit equation 23
Display Equation command 33
Display R"2 instead of R check box 35
displaying

curve fit coefficients 34

curve fit equations 33

E

Edit General command 18-21
editing

curve fit color 43

curve fit equations 33

curve fit line style 43

curve fit line width 43

master curve fit list 18

variable color 43

variable line style 43

variable line width 43
entering custom curve fit definition 23
Equation Label Format command 33
equations

Chi Square 35, 50

General curve fit 50

R 50

See also curve fit equations
errors, General curve fit results 35
Exponential curve fit

data restrictions 9

description 9

function 9

reference 49
Extrapolate Fit to Axis Limits check box 44
extrapolating curve fits 43

F

Force Line fit through zero check box 45
Formula Entry, calculating values from a fit 38—41

G

General curve fit 14-27

adding a new fit 18

adding fits to saved plots 20
affect on Macro Calculator 27
applying 24-25

Chi Square 35

constructing equation 14

Curve Fit Definition dialog 15
curve fit equation 14

description 13

entering custom curve fit definition 23
equations 50

importing definitions 21-22
importing definitions from a text file 21
importing library definitions 22
initial conditions 15

limiting parameters 27

master curve fit list 18
multivariate fits 26

parameter errors 35

predefined equations 21-22
rearranging a curve fit 19
reference 49

removing a curve fit definition 19
saving changes 20

specifying partial derivatives 16
weighting data 26

General submenu 18-22

importing curve fit definitions 21-22
increasing number of curve fit points 45
initial conditions 15

Interpolate curve fit

data restrictions 30
description 30
reference 49

L

Least Squares curve fitting 5
Levenberg-Marquardt algorithm 6, 13
Library command 22

library, importing curve fit definitions 22
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limit() function 27
limits on parameters 27
line style

curve fit 43
variable 43

line width

curve fit 43
variable 43

Linear Correlation Coefficient 35
Linear curve fit

applying to log/semi-log scales 48
description 9

forcing through origin 45

function 9

reference 49

Logarithmic curve fit

data restrictions 9
description 9
function 9
reference 49

M

Macro Calculator 27

macro files, saving curve fit changes 20
master curve fit list 18-20

memory registers 27

multiple independent variables 26
multivariate fits 26

N

nonlinear curve fit 6

o)

obtaining values from a curve fit 38
origin 45

P

parameter
errors 35
limits 27
Polynomial curve fit
applying 10-11
description 9
function 9
reference 49
Power curve fit

data restrictions 9
description 9
function 9
reference 49

predefined curve fit definitions 21-22

R

R 35

R equation 50

R2 35

rearranging the master curve fit list 19
removing

curve fit 46
curve fit from master list 19

residuals 37

S

saving changes to Curve Fit menu 20
setting limits on parameters 27
Smooth curve fit

data restrictions 29
description 29
reference 49

Specify Partials check box 16

T
table() function 26

\'}

variable
color 43
line style 43
line width 43

viewing coefficients 34

w
Weight Data check box 16, 26
Weighted curve fit

data restrictions 29
description 29
reference 49

weights 16
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